import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((2ª|segunda)|(3ª|terça)|(4ª|quarta)|(5ª|quinta)|(6ª|sexta))(-feira)?$";
final String string = "2ª\n"
+ "3ª\n"
+ "4ª\n"
+ "5ª\n"
+ "6ª\n"
+ "2ª-feira\n"
+ "3ª-feira\n"
+ "4ª-feira\n"
+ "5ª-feira\n"
+ "6ª-feira\n"
+ "segunda\n"
+ "terça\n"
+ "quarta\n"
+ "quinta\n"
+ "sexta\n"
+ "segunda-feira\n"
+ "terça-feira\n"
+ "quarta-feira\n"
+ "quinta-feira\n"
+ "sexta-feira\n\n"
+ "oitava-feira\n\n"
+ "segunda-\n"
+ "2ª2ª-feira\n"
+ "-feira\n"
+ "feira\n"
+ "22ª\n"
+ "1ª\n"
+ "7ª\n"
+ "ª\n"
+ "aquartado\n"
+ "sextavado";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}