# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((2ª|segunda)|(3ª|terça)|(4ª|quarta)|(5ª|quinta)|(6ª|sexta))(-feira)?$"
test_str = ("2ª\n"
"3ª\n"
"4ª\n"
"5ª\n"
"6ª\n"
"2ª-feira\n"
"3ª-feira\n"
"4ª-feira\n"
"5ª-feira\n"
"6ª-feira\n"
"segunda\n"
"terça\n"
"quarta\n"
"quinta\n"
"sexta\n"
"segunda-feira\n"
"terça-feira\n"
"quarta-feira\n"
"quinta-feira\n"
"sexta-feira\n\n"
"oitava-feira\n\n"
"segunda-\n"
"2ª2ª-feira\n"
"-feira\n"
"feira\n"
"22ª\n"
"1ª\n"
"7ª\n"
"ª\n"
"aquartado\n"
"sextavado")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.