import Foundation
let pattern = #"(\d)(?=(\d\d\d)+\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"1234567890"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)