$re = '/(?<=<BASE)\s+href="(.*)(?=")/';
$str = '<BASE href="http://whatreallyhappened.com/">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);