import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![^\\s])\\{[^\\}]*\\}\\t?";
final String string = "Shutdown Latest News {null}{10/15/2013} {10/15/2013} words words words.\n"
+ "Email Flow in Exchange {null}{10/17/2013} {10/17/2013} words words words....\n"
+ "Should This be banned? {null}{10/23/2013} {10/23/2013} words words words....";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}