package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\₱]{0,1}[0-9]*[.]{0,1}[0-9]{0,2}`)
var str = `100.0
100.00
₱100.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}