$re = '/^(?:\d{2}-\d{2}(?:;|$))+$/';
$str = '10-02;34-05;12-12;23-05;10-42;44-05';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);