import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^ ]+)*.(\\w{0,2}).([0-9]+)*.(.*.)";
final String string = "Yu.Yu.Hakusho Ep.001 - A Morte";
final String subst = "\\1.S01E\\3\\4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}