use strict;
my $str = 'Yu.Yu.Hakusho Ep.001 - A Morte';
my $regex = qr/([^ ]+)*.(\w{0,2}).([0-9]+)*.(.*.)/p;
my $subst = '\\1.S01E\\3\\4';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";