using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{4})-(\d{2})-(\d{2})(.*)";
string substitution = @"\1/\2/\3\4";
string input = @"2015-09-03/q-502-0720101527-20150903-080112-1441260058.1085767.wav49";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}