$re = '/(%({)?([A-Za-z0-9]+)(?(2)}))/';
$str = 'asdfasdfds%{ASDF}sdfasdf %asdsa
Match either %MACRO or %{MACRO}, but not ${MACRO nor %MACRO}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);