package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^.?!;\u2026]+[.?!;\u2026]+)`)
var str = `First sentence… Second sentence.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}