using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*~(.*)\|";
string input = @"|2~21381030213jafjs231|adfafafasdfas";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}