re = /<input type='hidden' name='auth_key' value='(.*?)' \/>/
str = '<input type=\'hidden\' name=\'auth_key\' value=\'880ea6a14ea49e853634fbdc5015a024\' />'
# Print the match result
str.match(re) do |match|
puts match.to_s
end