const regex = /<img.*src="(.*)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*src="(.*)"', 'g')
const str = `<div class="row">
<!-- 注意里面三个 img 标签是在同一行 -->
<img src="https://static.fastadmin.net/assets/images/app/code.png" alt=""> <img src="https://static.fastadmin.net/assets/images/app/browser.png" alt=""> <img src="https://static.fastadmin.net/assets/images/app/laptop.png" alt="">
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}