import Foundation
let pattern = #"<img.*src="(.*)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="row">
<!-- 注意里面三个 img 标签是在同一行 -->
<img src="https://static.fastadmin.net/assets/images/app/code.png" alt=""> <img src="https://static.fastadmin.net/assets/images/app/browser.png" alt=""> <img src="https://static.fastadmin.net/assets/images/app/laptop.png" alt="">
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)