# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[0-9]{14}$"
test_str = ("+21234567891\n"
"012345678913\n"
"+01234567891\n"
"0212 3456 7891\n"
"(+034) 1234 9132 0212\n"
"034 567 8910 1212\n"
"034 567 8912 1234\n"
"+1 230 4567 7894 \n"
"+44 123 3456 3445 \n"
"+21 234 5678 9134\n"
"9999999999999\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.