package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(?:name:\s*(\S+)).*?(?:no:\s*(\d+)).*?(?:new:\s*(yes))?.*?(?:dob:\s*(\d{2}-\d{2}-\d{4})).*(?:sal:\s*(\d+))`)
var str = `Name: abc
No: 1234
new: yes
DOB: 06-07-1992
sal: 40000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}