const regex = /(?:name:\s*(\S+)).*?(?:no:\s*(\d+)).*?(?:new:\s*(yes))?.*?(?:dob:\s*(\d{2}-\d{2}-\d{4})).*(?:sal:\s*(\d+))/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:name:\\s*(\\S+)).*?(?:no:\\s*(\\d+)).*?(?:new:\\s*(yes))?.*?(?:dob:\\s*(\\d{2}-\\d{2}-\\d{4})).*(?:sal:\\s*(\\d+))', 'gis')
const str = `Name: abc
No: 1234
new: yes
DOB: 06-07-1992
sal: 40000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}