use strict;
my $str = 'Name: abc
No: 1234
new: yes
DOB: 06-07-1992
sal: 40000';
my $regex = qr/(?:name:\s*(\S+)).*?(?:no:\s*(\d+)).*?(?:new:\s*(yes))?.*?(?:dob:\s*(\d{2}-\d{2}-\d{4})).*(?:sal:\s*(\d+))/isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}