using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name:\s*(\S+).*?no:\s*(\d+)(?:.*?new:\s*(yes))?.*?dob:\s*(\d{2}-\d{2}-\d{4}).*sal:\s*(\d+)";
string input = @"Name: abc
No: 1234
new: yes
DOB: 06-07-1992
sal: 40000";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}