# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\/.]+\/(?0)?\.\.\///g;t' <<< "out/src/../pictures/all/image.jpg
out/pictures/all/image.jpg
deep/hey there/folder/out/src/../../../pictures/all/image.jpg
deep/hey there/out/src/../../pictures/all/image.jpg
deep/hey there/out/../pictures/all/image.jpg
deep/hey there/pictures/all/image.jpg"