#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^/.]+/(?0)?\.\./"
Local $sString = "out/src/../pictures/all/image.jpg" & @CRLF & _
"out/pictures/all/image.jpg" & @CRLF & _
"" & @CRLF & _
"deep/hey there/folder/out/src/../../../pictures/all/image.jpg" & @CRLF & _
"deep/hey there/out/src/../../pictures/all/image.jpg" & @CRLF & _
"deep/hey there/out/../pictures/all/image.jpg" & @CRLF & _
"deep/hey there/pictures/all/image.jpg"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)