package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^/.]+/(?0)?\.\./`)
var str = `out/src/../pictures/all/image.jpg
out/pictures/all/image.jpg
deep/hey there/folder/out/src/../../../pictures/all/image.jpg
deep/hey there/out/src/../../pictures/all/image.jpg
deep/hey there/out/../pictures/all/image.jpg
deep/hey there/pictures/all/image.jpg`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}