// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^/.]+/(?0)?\.\./").unwrap();
let string = "out/src/../pictures/all/image.jpg
out/pictures/all/image.jpg
deep/hey there/folder/out/src/../../../pictures/all/image.jpg
deep/hey there/out/src/../../pictures/all/image.jpg
deep/hey there/out/../pictures/all/image.jpg
deep/hey there/pictures/all/image.jpg";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}