#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)night (.*)|Total(.*)"
Local $sString = "<strong class="price scarcity_color sr_gs_rackrate_price" & @CRLF & _
" anim_rack_rate " & @CRLF & _
"" title="Price for 1 night £69">" & @CRLF & _
"<b>" & @CRLF & _
"<span class="sr_gs_rackrate_total">Total: </span>" & @CRLF & _
"£69" & @CRLF & _
"</b>" & @CRLF & _
"</strong>" & @CRLF & _
"<td class="totalPrice" colspan="3">" & @CRLF & _
"<div data-component="track" data-hash="OLNYSRfCbdWGffSRe" data-stage="1" data-track="view"></div>" & @CRLF & _
"Total: £145" & @CRLF & _
"</td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")