use strict;
my $str = '<r p="68154" c="36716" t="1" d="1"/><r p="68139" c="36697" t="1" d="1"/><r p="68082" c="36655" t="1" d="1"/><r p="280" c="401" t="1" d="1"/><r p="262" c="363" t="1" d="1"/><r p="262" c="30" t="2" d="0"/><r p="113" c="202" t="1" d="1"/><r p="113" c="12" t="3" d="0"';
my $regex = qr/[\w-]+="[^"]*"/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}