using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[['](.*?\(Delete\).*?)[\]']";
string input = @"blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}