re = /[['](.*?\(Delete\).*?)[\]']/
str = 'blah blah [manikv (Delete) 4916258] blah blah
blah blah \'morl20 (Delete) 180977\' blah blah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end