#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\+(\b\w{1,2}\b)"
Local $sString = "+a +ab +string +of +words +with +different +lengths"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)