using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+(\b\w{1,2}\b)";
string substitution = @"$1";
string input = @"+a +ab +string +of +words +with +different +lengths";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}