#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\.][a-zA-Z0-9_\.+-]+[^\.]@[^-][a-zA-Z0-9-]+\.[a-zA-Z0-9-\.]+$" & @CRLF & _
""
Local $sString = ".email@example.com" & @CRLF & _
"email.@example.com" & @CRLF & _
"email@example.com (Joe Smith)" & @CRLF & _
"email@-example.com" & @CRLF & _
"email@111.222.333.44444"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")