import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\.][a-zA-Z0-9_\\.+-]+[^\\.]@[^-][a-zA-Z0-9-]+\\.[a-zA-Z0-9-\\.]+$\n";
final String string = ".email@example.com\n"
+ "email.@example.com\n"
+ "email@example.com (Joe Smith)\n"
+ "email@-example.com\n"
+ "email@111.222.333.44444";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}