$re = '/^[^\.][a-zA-Z0-9_\.+-]+[^\.]@[^-][a-zA-Z0-9-]+\.[a-zA-Z0-9-\.]+$
/m';
$str = '.email@example.com
email.@example.com
email@example.com (Joe Smith)
email@-example.com
email@111.222.333.44444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);