$re = '/^\S+\^(\d+)(?=\^)/';
$str = 'abc^28092015^def^1234.';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;