using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",\n]$";
string substitution = @"\n]";
string input = @"[
{
""ITEM1"":{
""names"":[
""nameA""
]
}
},
{
""ITEM2"":{
""names"":[
""nameB"",
""nameC""
]
}
},
]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}