// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r",\n]$").unwrap();
let string = "[
{
\"ITEM1\":{
\"names\":[
\"nameA\"
]
}
},
{
\"ITEM2\":{
\"names\":[
\"nameB\",
\"nameC\"
]
}
},
]";
let substitution = "\\n]";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}