# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(\G|<p class=\"oyric\">)((?!</p>).)*?\K((?<=>)\h+|\h+(?=<|\h))"
test_str = (" <div align=\"justify\">\n"
" <table width=\"552\" border=\"0\">\n"
" <tr>\n"
" <td><h1 class=\"article\" itemprop=\"name\">Modals</h1></td>\n"
" </tr>\n"
" <tr>\n"
" <td class=\"text_dreapta\">On February 25, 2011, in <a href=\"modals.html\" title=\"View all articles from Modals\" class=\"external\" rel=\"category tag\">Destiny</a>, by Roland Worrior</td>\n"
" </tr>\n"
" </table>\n"
" <p class=\"text_obisnuit2\"><em>Should I stay or should I go?</em></p>\n"
" <p class=\"oyric\"> Laurie Strode comes to her final confrontation with Michael Myers, the masked figure who has haunted her since she narrowly escaped. </p>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.