package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'[^INFO]*'`)
var str = `[INFO] some info
no info
'' sup
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}