import Foundation
let pattern = #"^([^\-]*\-){7}(?<your_field>\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-423447
bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-6672
bdf73ad5-4499-4f70-b7e3-e2c81ae868c3-default-asset-4232323
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)