Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(-?\d+)(,?\d+)*(\.\d+(e\d+)?)?$
/
gm
Input 1
1
New
123,340.00 1.9e10 125 -255.34 3.14529 720p