re = /ip=(?|0\.0\.0\.0.*?host=(\S+)|(\d+\.\d+\.\d+\.\d+))/
str = 'Foo bar ip=0.0.0.0 baz host=YOLO-PC foobar bazinga
Foo bar ip=12.23.34.45 baz host=FOOBAR-PC foobar bazinga'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end