package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(PackageQuantity:|(Servings)?PerContainer:|(Servings)?PerPackage:)[a-zA-Z.]*(\d+)`)
var str = `ServingsPerContainer:about11
PackageQuantity:approx.12
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}