$re = '/ *(?=\d)/';
$str = ' 11 BELIZE
10 TONGA
10 CONGO DEM. REP.
10 BHUTAN
10 ANGOLA
9 MALDIVES
9 COOK ISLANDS
9 CAYMAN ISLANDS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);