import re
regex = re.compile(r"^(?=^(?:(\d\d(?:[02468][048]|[13579][26]))-02-29|\d{4}-(?:0[13578]|1[02])-31|\d{4}-(?:0[13-9]|1[0-2])-30|\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|1\d|2[0-8])))(\d{4})-(\d\d?)-(\d\d?)(?:\x20(\d{2}):(\d{2})(?::(\d{2})(.\d+)?)?)?$", flags=re.MULTILINE)
test_str = ("This captures the year, month and day of a date at the 2nd, 3rd and 4th groups.\n"
"Also captures leap years in day 29 of February in 1st capturing group.\n"
"2014-05-31\n"
"2016-02-29\n"
"2004-08-10 13:02\n"
"2002-02-08 19:35:00\n"
"1999-12-31 23:59:59.999\n"
"1996-02-29 23:59:59.9999\n"
"Regex used: ^(?=^(?:(\\d\\d(?:[02468][048]|[13579][26]))-02-29|\\d{4}-(?:0[13578]|1[02])-31|\\d{4}-(?:0[13-9]|1[0-2])-30|\\d{4}-(?:0[1-9]|1[0-2])-(?:0[1-9]|1\\d|2[0-8]))$)(\\d{4})-(\\d\\d?)-(\\d\\d?)$")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")