#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)this\.dialogs = {.*};"
Local $sString = " this.dialogs = {" & @CRLF & _
" errorDialogComponent: ko.observable()," & @CRLF & _
" searchIndividualsDialogComponent: ko.observable()," & @CRLF & _
" searchAccountsDialogComponent: ko.observable()," & @CRLF & _
" addBlocksDialogComponent: ko.observable()," & @CRLF & _
" deleteBlocksDialogComponent: ko.observable()," & @CRLF & _
" folioGroupDialogComponent: ko.observable()," & @CRLF & _
" groupServicesOverviewDialogComponent: ko.observable()," & @CRLF & _
" roomingListDialogComponent: ko.observable()" & @CRLF & _
" };"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")