using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"this\.dialogs = {.*};";
string input = @" this.dialogs = {
errorDialogComponent: ko.observable(),
searchIndividualsDialogComponent: ko.observable(),
searchAccountsDialogComponent: ko.observable(),
addBlocksDialogComponent: ko.observable(),
deleteBlocksDialogComponent: ko.observable(),
folioGroupDialogComponent: ko.observable(),
groupServicesOverviewDialogComponent: ko.observable(),
roomingListDialogComponent: ko.observable()
};";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}