package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)this\.dialogs = {.*};`)
var str = ` this.dialogs = {
errorDialogComponent: ko.observable(),
searchIndividualsDialogComponent: ko.observable(),
searchAccountsDialogComponent: ko.observable(),
addBlocksDialogComponent: ko.observable(),
deleteBlocksDialogComponent: ko.observable(),
folioGroupDialogComponent: ko.observable(),
groupServicesOverviewDialogComponent: ko.observable(),
roomingListDialogComponent: ko.observable()
};`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}