const regex = /^0x[a-fA-F0-9]{40}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0x[a-fA-F0-9]{40}$', 'g')
const str = `0xeB7C917821796eb627C0719A23a139ce51226CD2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}