package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\"[^"]*.*?)-(.*?\")`)
var str = `This is a test string with "quotation-marks" within it.
The "problem" I am having, per-se, is "knowing" which "quotation-marks"
go with which words.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}